Recommend
4 
 Thumb up
 Hide
35 Posts
Prev «  1 , 2  | 

BoardGameGeek» Forums » BoardGameGeek Related » BGG Bugs

Subject: Error in showing games in my collection rss

Your Tags: Add tags
Popular Tags: [View All]
Ron Price
United States
Columbus
Ohio
flag msg tools
It is pitch black.
badge
You are likely to be eaten by a grue.
Avatar
mbmbmbmbmb
I'm having the error, and got this in Firefox 56.0:

Error: config is null
utils.getPrettyStatus@https://cf.geekdo-static.com/static/geekcollection_master2_5...:38:14
this.getItems/</<@https://cf.geekdo-static.com/static/geekcollection_master2_5...:3:275
this.getItems/<@https://cf.geekdo-static.com/static/geekcollection_master2_5...:3:215
e/<@https://cf.geekdo-static.com/static/geekui_master2_59dbc6a45...:173:10670
$eval@https://cf.geekdo-static.com/static/geekui_master2_59dbc6a45...:173:18141
$digest@https://cf.geekdo-static.com/static/geekui_master2_59dbc6a45...:173:16682
$apply@https://cf.geekdo-static.com/static/geekui_master2_59dbc6a45...:173:18437
f/q<@https://cf.geekdo-static.com/static/geekui_master2_59dbc6a45...:176:1606
e@https://cf.geekdo-static.com/static/geekui_master2_59dbc6a45...:169:12102
$f/k.defer/c<@https://cf.geekdo-static.com/static/geekui_master2_59dbc6a45...:170:1341

Seems potentially related?

It does not appear when I load a page for a game that is already in my collection, or not on my wishlist--only for wishlist games.
1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Murr Rockstroh
United States
Fleming Island
Florida
flag msg tools
badge
Avatar
mbmbmbmbmb
Pretty much the same thing as far as I can tell in my web console logging tab in FF 56.0
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Ron Price
United States
Columbus
Ohio
flag msg tools
It is pitch black.
badge
You are likely to be eaten by a grue.
Avatar
mbmbmbmbmb
In playing around further, I discovered something else.

Kingdomino was on my wishlist, and visiting the page resulted in the perpetual "loading" button. When I searched for Kingdomino, and edited the status button on the search page (changing from the Wishlist to "owned"), and returned to the page, I found that nothing had changed. I played with selecting different dropdowns from the unchecked wishlist check box. Nothing changed.

So I thought, "I'll check what the wishlist checkbox of a game I've never had on my wishlist looks like." Searched for Le Havre and played around a bit--checked and unchecked the wishlist box. The collection box showed as entirely empty for me. However when I visit Le Havre's game page now, it shows as "in my collection" even though neither the "owned" box nor any other are checked.

Innnteresting...

Incidentally, these anomalies are happening the same way in Chrome. If I go to Safari, my wishlist items appear correctly, but Le Havre still shows as being in my collection, even though none of the boxes are checked. Also, it doesn't show as "In Collection (owned)" or "In Collection (Wishlist)", only as "In Collection."

Anything I can do to help?
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Murr Rockstroh
United States
Fleming Island
Florida
flag msg tools
badge
Avatar
mbmbmbmbmb
puzzlemonkey wrote:
In playing around further, I discovered something else.

Kingdomino was on my wishlist, and visiting the page resulted in the perpetual "loading" button. When I searched for Kingdomino, and edited the status button on the search page (changing from the Wishlist to "owned"), and returned to the page, I found that nothing had changed. I played with selecting different dropdowns from the unchecked wishlist check box. Nothing changed.

So I thought, "I'll check what the wishlist checkbox of a game I've never had on my wishlist looks like." Searched for Le Havre and played around a bit--checked and unchecked the wishlist box. The collection box showed as entirely empty for me. However when I visit Le Havre's game page now, it shows as "in my collection" even though neither the "owned" box nor any other are checked.

Innnteresting...

Incidentally, these anomalies are happening the same way in Chrome. If I go to Safari, my wishlist items appear correctly, but Le Havre still shows as being in my collection, even though none of the boxes are checked. Also, it doesn't show as "In Collection (owned)" or "In Collection (Wishlist)", only as "In Collection."

Anything I can do to help?
That's always been the case that this occurs. It will be included in your collection if you have ever checked a box for the game, unless you delete it from your collection entirely. It's in there, just not flagged specifically.

The original problem is still persisting for me though. I have noticed if I go into the search list and uncheck all the boxes, I can load up the page, and then get into the My Collection button to edit, and add the game, set version and all that stuff I want to do. It is a work around that works.

Just now, I went into my entry for Villa Paletti, which is flagged as "Owned" and "Want to Play"

It shows "Loading"

I went to the search list and went to the Status column, unchecked the boxes from there, then called up the game page by clicking the name.

It showed "In Collection" so I opened it up, hit Edit, rechecked the boxes for "Owned" and "Want to Play" then set the Version I have.

I hit save and it the Collection button was fine, and clickable.

I then refreshed the page, and it's back to "Loading" again.

Firefox 56.0.1

I don't know if this helps or not, but when I clicked "CSS" in the Web Console, it actually lists the game by name.


Error in parsing value for ‘top’. Declaration dropped. villa-paletti
Error in parsing value for ‘left’. Declaration dropped. villa-paletti
Unknown property ‘enable-background’. Declaration dropped. villa-paletti
Error in parsing value for ‘font-size’. Declaration dropped. villa-paletti
Error in parsing value for ‘width’. Declaration dropped. villa-paletti
Error in parsing value for ‘height’. Declaration dropped. villa-paletti


1 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Scott Alden
United States
Dallas
Texas
flag msg tools
admin
badge
Aldie's Full of Love!
Avatar
mbmbmbmb
Murr wrote:
fnord23 wrote:
Aldie wrote:

See if there's any error messages in the console. Or if you have the ability to look at the developer network tab and see if there's anything weird with /api/collections



Nothing in IE's console.

Also, perhaps related:

New Bug with Collection button on game page tied to Status column in table listing from Search


I looked around before posting my thread and must have missed this one, but yes, this is the same problem I'm having, and it started about the same time this thread was posted. There are errors in the Firefox Web console, should I post them here or geekmail them to someone?


Please email to me: aldie@boardgamegeek.com
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Murr Rockstroh
United States
Fleming Island
Florida
flag msg tools
badge
Avatar
mbmbmbmbmb
Email sent, I just copied everything, with all of the tabs turned on.
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Scott Alden
United States
Dallas
Texas
flag msg tools
admin
badge
Aldie's Full of Love!
Avatar
mbmbmbmb
Thank you all - I think I found the problem. It was a race condition in loading things from different places and that's why I couldn't reproduce it. My race always came out in the same order.

Anyway - should be working now.
2 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Murr Rockstroh
United States
Fleming Island
Florida
flag msg tools
badge
Avatar
mbmbmbmbmb
I checked a page and it does appear to be working, thank you!
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Ron Price
United States
Columbus
Ohio
flag msg tools
It is pitch black.
badge
You are likely to be eaten by a grue.
Avatar
mbmbmbmbmb
Murr wrote:
That's always been the case that this occurs. It will be included in your collection if you have ever checked a box for the game, unless you delete it from your collection entirely. It's in there, just not flagged specifically.


Huh. Did not know that. It's never come up for me before.

Today I learned about the Delete from Collection button, which I'd never noticed until now.

Also, all the games on my wishlist are displaying properly as well. Thanks, Aldie!
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Belgium
flag msg tools
mbmbmbmbmb
Yes, everything's working well again!

Thank you for raising the issue and thank you for solving the problem!
 
 Thumb up
 tip
 Hide
  • [+] Dice rolls
Prev «  1 , 2  | 
Front Page | Welcome | Contact | Privacy Policy | Terms of Service | Advertise | Support BGG | Feeds RSS
Geekdo, BoardGameGeek, the Geekdo logo, and the BoardGameGeek logo are trademarks of BoardGameGeek, LLC.